Results 1 to 3 of 3

Thread: Limp mode / G31 sensor / wiring (000568 / P0238)

  1. #1
    Junior Member
    Join Date
    May 2019
    Posts
    1
    Post Thanks / Like

    Limp mode / G31 sensor / wiring (000568 / P0238)

    Just posting this here in case anybody else in the future has the same problem and can avoid some of my headaches.

    The glow plug warning light started flashing and my car went into limp mode on Wednesday morning. Plugged in VCDS and got:

    000568 - Manifold Pressure / Boost Sensor (G31)
    P0238 - 000 - Signal too High - Intermittent
    Freeze Frame:
    Fault Status: 00100000
    Fault Priority: 2
    Fault Frequency: 1
    Reset counter: 255
    Mileage: 205201 km
    Time Indication: 0
    Date: 2052.14.01
    Time: 07:34:47

    Freeze Frame:
    RPM: 1748 /min
    Speed: 23.0 km/h
    Voltage: 14.14 V
    Absolute Pres.: 1009.8 mbar
    Absolute Pres.: 2601.0 mbar
    Temperature: 9.9C
    Temperature: 23.4C

    I replaced the G31 sensor (about 40 for an aftermarket one from ECP) but the code / warning light persisted. Following Ross-Tech's advice I looked into the wiring and doing some reading it seems this is a common fault on lots of VAG motors due to the routing of the harness from this sensor back to the ECU. So common in fact that VW produce a repair harness for this purpose - the part number is 1KD 971 658 and costs 36.18 inc VAT.

    This is a 4-wire harness that runs directly from the G31 sensor back to the 94 pin connector on the ECU under the wipers.

    I'm not sure what engine code the repair harness is designed for but the pin numbers marked on the wires indicated for the ECU don't match those on my car, which is the CBBB engine code. My pins are as follows:

    Brown -> 66
    Yellow -> 30
    Purple -> 83
    Grey/Black -> 17

    Replaced the connectors at the ECU with the ones from the wiring harness (you'll need the right tools to disengage the locking pins etc) and problem solved.

    Hope this helps someone else. Nice to be able to accelerate again!

  2. #2
    Administrator Keithuk's Avatar
    Join Date
    Jun 2012
    Location
    Stoke on Trent
    Posts
    13,782
    Post Thanks / Like
    First posts normally go in introductions else you could get a free fix and we never see you again!!!

    You made 2 post with the same text I've deleted the other one.

    VAG Error Code: 16622/15984/000568/4166/5169/7295
    EOBD II Error Code: P0238

    Fault Location:
    Manifold Pressure/Boost Sensor (G31) - Signal too High

    Possible Cause:
    Malfunction Indicator Lamp (MIL)(K83) active.

    Wiring/Connector(s).
    Manifold Pressure/Boost Sensor (G31) faulty.

    Possible Solutions:
    Check/Replace all faulty Wiring/Connector(s).
    Read Measuring Value Blocks (MVB).
    Check Manifold Pressure/Boost Sensor (G31).
    Signal voltage > 4.88 V.


    As taken from my new EOBD II Fault Codes Software
    2010 Golf GTD (170) CBBB, 5 Door, Shadow Blue (P6/D5Q), Transmission Code: KXZ, Flat Tyre Indicator, Basic Protection Pack + VCDS.


  3. #3
    Senior Member
    Join Date
    Jul 2017
    Location
    Gone
    Posts
    676
    Post Thanks / Like
    Keith; If you had bothered to read either post, you'd have realised that the OP doesn't need a free fix, he's OFFERING ONE.

    It's so unwelcoming to copy/paste your usual nonsense without even reading the post you're answering.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •