Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Engine starts and then stops after 3 seconds

  1. #1
    Junior Member
    Join Date
    Aug 2014
    Posts
    13
    Post Thanks / Like

    Engine starts and then stops after 3 seconds

    Hi, wonder if anybody can help please?

    2011 Caddy 1.6 TDI. Air bag light is on and after plugging into computer it tells me there is no power to the airbag module, so checked all fuses and noticed one fuse missing, so after placing a fuse in the slot and starting the engine, it runs and then stops after 3 seconds after. I then removed the fuse but still does the same thing. Outside of the fact I shouldn’t have put a fuse in the slot in the first place! Anybody have any ideas please?
    2011 Caddy 1.6 TDI-CR

  2. #2
    Administrator Keithuk's Avatar
    Join Date
    Jun 2012
    Location
    Stoke on Trent
    Posts
    15,734
    Post Thanks / Like
    First posts normally go in introductions else you could get a free fix and we never see you again!!!

    Your car spec said 0, I added 04 Caddy from your other posts. Now I see you have changed this to 2011 Caddy 1.6 TDI so I've updated your signature.

    Starts and then stops after 3 seconds could be many things.

    You need to get your motor scanned (preferably with VAG-COM\VCDS) for any error codes logged in the ecu and post them, that will save a lot of guessing and check systems out.
    2010 Golf GTD (170) CBBB, 5 Door, Shadow Blue (P6/D5Q), Transmission Code: KXZ, Flat Tyre Indicator, Basic Protection Pack + VCDS.


  3. #3
    Junior Member
    Join Date
    Aug 2014
    Posts
    13
    Post Thanks / Like
    OK, will do that and then post. Thanks for your trouble in replying.
    2011 Caddy 1.6 TDI-CR

  4. #4
    Administrator Crasher's Avatar
    Join Date
    Apr 2006
    Location
    Nottingham, England
    Posts
    23,687
    Post Thanks / Like
    You have no dash feed, that is where the immobiliser is.
    "I disapprove of what you say, but I will defend to the death your right to say it"

    Evelyn Beatrice Hall (28 September 1868 13 April 1956)

  5. #5
    Administrator Keithuk's Avatar
    Join Date
    Jun 2012
    Location
    Stoke on Trent
    Posts
    15,734
    Post Thanks / Like
    With an immobiliser problem it will only start for a second or two, it depends on how long you count for.
    2010 Golf GTD (170) CBBB, 5 Door, Shadow Blue (P6/D5Q), Transmission Code: KXZ, Flat Tyre Indicator, Basic Protection Pack + VCDS.


  6. #6
    Junior Member
    Join Date
    Aug 2014
    Posts
    13
    Post Thanks / Like
    Ok, have scanned the system now and can get no connection to any control units AT ALL.
    The fuse I put in was on mini slot No 7 and the wire coming off the back of it is a black/White tracer, with an earth.
    Also anybody know the fuse location for the OBD, please?
    2011 Caddy 1.6 TDI-CR

  7. #7
    Administrator Crasher's Avatar
    Join Date
    Apr 2006
    Location
    Nottingham, England
    Posts
    23,687
    Post Thanks / Like
    So this is the under dash fuse box not the one in the engine bay. The main area of the one in the engine bay is called SB and the big fuses on the front called SA, the one inside the cab is called SC. Oddly the fuse here start at 9 so what you see as 7 is actually SC15 and this provides an ignition live "Line 15" power to the air bag ECU via a black/white 0.5mm CSA wire that goes to a junction in the air bag harness where it splits off into two separate line 15 feeds to the air bag ECU (J234) and off the the K154 passengers side air bag deactivated warning light. The 16 pin diagnostic plug "U31" gets its switch live "line 15" at pin 1 from fuse SC14 on the green/red and the permanent live "Line 30" at pin 16 on the red/white from SC21, remembering that these fuses start at number 9.
    "I disapprove of what you say, but I will defend to the death your right to say it"

    Evelyn Beatrice Hall (28 September 1868 13 April 1956)

  8. #8
    Junior Member
    Join Date
    Aug 2014
    Posts
    13
    Post Thanks / Like
    OK, the dash does light up and works though?
    Is there a sequence for getting the immobiliser off?
    2011 Caddy 1.6 TDI-CR

  9. #9
    Administrator Keithuk's Avatar
    Join Date
    Jun 2012
    Location
    Stoke on Trent
    Posts
    15,734
    Post Thanks / Like
    As I've said With an immobiliser problem it will only start for a second or two, it depends on how long you count for. The immobiliser light will come on in the dash.

    VAG-COM\VCDS will only scan for error codes and systems it won't turn the immobiliser off.
    2010 Golf GTD (170) CBBB, 5 Door, Shadow Blue (P6/D5Q), Transmission Code: KXZ, Flat Tyre Indicator, Basic Protection Pack + VCDS.


  10. #10
    Administrator Crasher's Avatar
    Join Date
    Apr 2006
    Location
    Nottingham, England
    Posts
    23,687
    Post Thanks / Like
    The immobilser is not your problem, you know when that is acting as the engine stars and cuts, you have no power to the CAN BUS unit amongst others. Check the diagnostic plug for ignition live at pin 1 and permanent live at pin 16, be gentle probing the terminals.
    "I disapprove of what you say, but I will defend to the death your right to say it"

    Evelyn Beatrice Hall (28 September 1868 13 April 1956)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •