Results 1 to 8 of 8

Thread: SDI Wont start on hill

  1. #1
    Member
    Join Date
    Mar 2019
    Location
    Kent
    Posts
    48
    Post Thanks / Like

    SDI Wont start on hill

    Hi im having issues again with the van. Some self diagnosis has led me to believe its failing to start when facing uphill (this is the second time its happened). I did take it in to VAGS garage the first time when it finally started but was told they couldnt find anything wrong and I would need to take it in when its dead. It died again yesterday and green flag got it started, they not sure what the issue is but they took off pipe to fuel filter to confirm delivery which was ok, they also removed the return fuel pipe I think and reattached it, after which some cranking it started.

    So Ive been reading various forums and realised it could be a tiny hole in a fuel line causing the system to lose its suction and allow the fuel to drain back into the tank, or that its someink to do with a non return valve in the fuel rail. Anyone have any pointers as to where to start looking ?

    When the van is running its fine, and it starts fine when its warm facing uphill or downhill. If its left overnight or for 5-6 hours facing uphill this is when the problems starting it.

    Can anyone recommend where to start looking and save me some cash ! Thanks

    Van is 2009 Caddy 2.0 SDI engine btw
    Last edited by jameson; 01-12-19 at 00:14.
    2009 Caddy 2.0 SDI BTS

  2. #2
    Administrator Crasher's Avatar
    Join Date
    Apr 2006
    Location
    Nottingham, England
    Posts
    23,952
    Post Thanks / Like
    Which engine type code? Does the tank being low make a difference and has it had a fuel filter recently?
    "I disapprove of what you say, but I will defend to the death your right to say it"

    Evelyn Beatrice Hall (28 September 1868 13 April 1956)

  3. #3
    Member
    Join Date
    Mar 2019
    Location
    Kent
    Posts
    48
    Post Thanks / Like
    Quote Originally Posted by Crasher View Post
    Which engine type code? Does the tank being low make a difference and has it had a fuel filter recently?
    Yes its the BST engine code, the fuel filter was changed about 8 months ago when I had a faulty injector replaced, I never put any more than 20 of diesel in at a time, so not really sure if it makes a difference if the fuel is low. When it wouldnt start I suppose it had about 10 of diesel in the tank !
    Last edited by jameson; 01-12-19 at 20:41.
    2009 Caddy 2.0 SDI BTS

  4. #4
    Administrator Crasher's Avatar
    Join Date
    Apr 2006
    Location
    Nottingham, England
    Posts
    23,952
    Post Thanks / Like
    You need to check if the in tank lift pump is delivering fuel.
    "I disapprove of what you say, but I will defend to the death your right to say it"

    Evelyn Beatrice Hall (28 September 1868 13 April 1956)

  5. #5
    Member
    Join Date
    Mar 2019
    Location
    Kent
    Posts
    48
    Post Thanks / Like
    Quote Originally Posted by Crasher View Post
    You need to check if the in tank lift pump is delivering fuel.
    I really think it is, I can hear it every time i turn ignition. The rac guy also checked this by removing line into fuel filter and having me turn on/off ignition for 2 seconds. The van will not start when facing uphill, all other times it starts fine. I was thinking its either a hole in a fuel line or a faulty tandem pump. TBH after looking online this appears a fairly common fault on these vans, anyone come across this before ?
    Last edited by jameson; 02-12-19 at 20:02.
    2009 Caddy 2.0 SDI BTS

  6. #6
    Administrator Crasher's Avatar
    Join Date
    Apr 2006
    Location
    Nottingham, England
    Posts
    23,952
    Post Thanks / Like
    Holed fuel lines are very rare and pretty obvious (and smelly) but faulty tandem pumps are virtually unheard of, since the PD TDI came along I have yet to see a faulty one other than them contaminating the fuel system with engine oil.
    "I disapprove of what you say, but I will defend to the death your right to say it"

    Evelyn Beatrice Hall (28 September 1868 13 April 1956)

  7. #7
    Member
    Join Date
    Mar 2019
    Location
    Kent
    Posts
    48
    Post Thanks / Like
    Its a mystery, all I know is it wont start after being left facing uphill for an hour or two; my thoughts are that somehow the primed fuel is returning to the tank maybe via a faulty check valve (there is one within the tandem pump); or that there's fuel pressure being lost from the system via a line pinhole or some such thing. Any advice is appreciated. As I said I took it in to a VAGS garage, they run a diog and cannot find anything wrong, and said to bring it in when its dead, which is a logistical pita !
    2009 Caddy 2.0 SDI BTS

  8. #8
    Member
    Join Date
    Mar 2019
    Location
    Kent
    Posts
    48
    Post Thanks / Like
    Quote Originally Posted by Crasher View Post
    Holed fuel lines are very rare and pretty obvious (and smelly) but faulty tandem pumps are virtually unheard of, since the PD TDI came along I have yet to see a faulty one other than them contaminating the fuel system with engine oil.
    Engine does not have a turbo btw crasher !!
    2009 Caddy 2.0 SDI BTS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •