Results 1 to 2 of 2

Thread: 2014 Polo BlueGT clutch pedal creak - ongoing issue.

  1. #1
    Junior Member
    Join Date
    Jan 2020
    Posts
    1
    Post Thanks / Like

    2014 Polo BlueGT clutch pedal creak - ongoing issue.

    As my car is still under warranty, I took it back to the main dealer which I bought it from and explained the issue to them. Long story short, the technician simply put some high-temperature grease in the clutch pedal assembly, only for the noise to reoccur.

    Took my car back yesterday for the same issue, again, a technician applied some grease and this time bled the clutch and yet again, the creak still remains. I got told on the job sheet that and I quote "May need 4 hours strip down to assess clutch".

    Now, I'm not saying that they're simply trying to get some money out of me, however, I feel there could be another cause for this noise, as in a bad clutch slave cylinder? Opinions? Should I take my car to an independent garage or is their an easy fix?

    Video of the noise:

    Thanks.

  2. #2
    Administrator Keithuk's Avatar
    Join Date
    Jun 2012
    Location
    Stoke on Trent
    Posts
    18,575
    Post Thanks / Like
    First posts normally go in introductions else you could get a free fix and we never see you again!!!

    Its still under warranty keep onto the dealer to fix this problem.

    Post moved to the correct section as its not a general question.
    2010 Golf GTD (170) CBBB, 5 Door, Shadow Blue (P6/D5Q), Transmission Code: KXZ, Flat Tyre Indicator, Basic Protection Pack + VCDS.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •