Audi A4 1.9TDI B7 (2006)

ionelbesliu

New member
Joined
Nov 21, 2020
Messages
2
Hello this is my first time posting, I have had an issue with my Audi for a while now where it makes a kind of swirling sound (a bit like a boost leak) it just sounds like air is being sucked in whenever the car is on boost or the turbo is operating around 1.5k rpm and all the way up through all the gears. It also smokes quite a bit whenever I accelerate and sometimes when I let off the accelerator it judders a bit. There also seems to be a period of time when I’ll be accelerating and the car will kind of struggle and suddenly it powers off with a pile of smoke in the back. Luckily I work with Audi so I managed to plug it in and I got the fault code P2099 turbo underboost and another fault code for the MAF sensor. Could this all be due to a faulty MAF sensor? Or is the problem more internally like a faulty turbo or a blocked EGR? The car has 164000 miles, any help is appreciated!
 

Crasher

Administrator
Staff member
Joined
Apr 22, 2006
Messages
24,893
Location
Nottingham, England
That suggests the hose from the turbo to the intercooler link pipe is split, it is a very common problem and so the hose is readily availble for a fraction of the Audi £61.27. The part number for a BKE or BRB engine is 8E0 145 738 H

1606223788555.png
 

ionelbesliu

New member
Joined
Nov 21, 2020
Messages
2
Just bought a new MAF sensor today i removed all the intake system to look at the turbo but I didn’t think about checking that particular pipe :( they’re not the easiest to get to but I’ll have another look before I start buying any replacement intake pipes
 
Top