Diagnostic Data Interface gateway - 01044 replacement radio? 37- NAV-System - Bigger issues!

JimR_69

New member
Joined
Jan 8, 2022
Messages
13
Hi
I recently purchased my Caddy, it had reasonably low mileage and only two owners. Book is stamped but the previous garage were not really very helpful and the repair and fault history is very sparse.

I have fitted a replacement DAB radio into my Caddy and aerials microphone etc. to enable the VW RNS 315 DAB to work. The parking sensors, GPS, DAB, phone connectivity etc. work fine but I have a code 01044 in 19-Diagnostic which may or may not be relating to this?

Also I believe I need to tell the ECU that I have fitted SATNAV, this just says I have 5 code issues 1000H/4096 all the same

I have resolved one issue P2279 which I commented on in another thread, this was an air leak and resolved by correctly fitting the turbo pipe.

I have noted that the EGR valve appears to have been changed as it seems to have a 2017 production date stamp on it and the top bolt at the back of the DPF is missing. I currently have a SOLUS EDGE at my disposal and this is how I have been able to read the codes and reset the P2279 code to clear the air leak. I have also been able to establish that the system has not performed a regen in quite some time and I have changed the oil and filter (it was a bit overfull and due a service) and performed a satisfactory static regen after changing the thermostat (this is not a fun job but all sorted and running at 90'C now)

I drove the vehicle for 170miles yesterday at prolonged 50mph, 60mph, 70mph and it accelerates fine up to over the speed limit from 70mph in 5th. It will easily rev out in the lower gears but seems rather slow after my wife's car which has around 170bhp...

At 70mph on the motorway it has just over 1.5psi of back pressure at the DPF, foot hard down on the accelerator with the turbo making pressure the DPF back pressure rises to about 2.6psi this doesn't seems too high but confirmation of this would be appreciated.

What I have got from the full scan is that the readiness monitors for the EGR/VVT, Boost pressure system, exhaust gas sensor and the PM filter have not been completed could this be because of the 01040 code is stalling the interrogation? Or is there bigger issues maybe?

If if perform an actuator test I cannot hear the EGR operating either and previous experience is that they are not usually quiet in operation without the engine running, any suggestions for this would be greatly appreciated.

Sorry this is war and peace
Regards
JimR
 

JimR_69

New member
Joined
Jan 8, 2022
Messages
13
Hi Crasher
In the list it shows a radio, not a GPS Radio, I have sorted most of the other codes and just left with this issue. I was either contemplating refitting the old radio so I can connect with it to remove it and then refit the 315 DAB, or just uncheck Radio 56 and check 37 GPS radio but I cannot seem to find where to check or uncheck these items?

Some of the codes refer to rear speakers which I don't have, I was able to change this to front only and the only code I have now is for aerial 2 which is open circuit (or something like that). I assume this must be one of the mirror aerials? Not sure which one?

The other items seems fine now and now codes, the functional testing of the EGR seems to be fine and you can here it opening and closing if it is quite outside, throttle, EGR solenoid etc. all seem to be working and the EGR seems to be modulating on the graphical output so assume this is happy..
 
Top