UK Volkswagen Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Last week my golf went in for a service and I got the cambelt and water pump done. Yesterday I pulled off my drive and it seemed to "slip" a gear.. the emissions control lamp came on (yellow engine) and where the display shows the gear its in It showed a flashing spanner.
The car drives but won't go into any gears other than 2[SUP]nd[/SUP] and 4[SUP]th[/SUP] once the spanner has appeared
When the car is turned off and back on the emissions light is still on, but the gears problem seems to re-set. It then happens again when the car gets enough speed to attempt to change from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP]… again it jumps to 4[SUP]th[/SUP] and then not allowing you into any other gears..

I took it back to the VW garage that did the work last week and they tested the faults etc.
The fault found says:
005946 - Position sensor 1 for gear selector
P173A - 000 - Implausible Signal - Intermittent - MIL ON
Freeze Frame:
Fault Status: 10100000
Fault Priority: 0
Fault Frequency:9
Reset counter: 40
Mileage 24344 K
Time Indication: 0
Date 2001.14.16
Time: 15:15:21

The garage suggests it needs a new Mechatronic about £1600 Fitted
Also suggest that the Clutch and dual mass are done at the same time (because of the high mileage) at a further £1400
Total £3000… probably as much as the car is worth.

Any advice? And other options you can suggest I pursue? I spent £570 on the car last week and a further £3000 on a car with 150000 miles seems foolish.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
That's a new code for me which you can Google?

0AM DSG Fault codes P173A P173B P173C P173D P173E P173F
Thanks for your reply. I sadly dont have much knowledge in this area. I didnt think to google it. thanks for finding that.

I will take it to someone local to check over with that info. how exact do the fault codes need to be? does that suggest it is def the problem with the magnets or just another it maybe that? cheers Geoff
 

·
Registered
Joined
·
18,929 Posts
You can search for anything on Google (other search engines are available) ;)

Finding someone with VAG-COM\VCDS you can for a full AutoScan for any error codes and save the log file for reference. You can check components to see if the readings are within tolerance.

After reading your post I've now added 6 more error codes to my new app EOBD II Fault Codes Software
 

·
Registered
Joined
·
133 Posts
Really hard to understand why you should change whole mechatronics in this situation. Also if cluthes and flywheel are ok dont touch them. Take car to someone who does DSG boxes. If the sensor is bad only sensor should be changed.
 

·
Registered
Joined
·
18,929 Posts
I'm sure I've seen a thread about mechatronics where Crasher said the oil affects the solder in the mechatronic unit. I've searched but I can't find it, maybe Crasher knows where it is?
 

·
Administrator
Joined
·
32,476 Posts
Yes but the Mechatronic operation of the clutch is by oil and the gearbox has oil. The synthetic oil in the box itself attacked the solder joints on the circuit board so the oil was changed to mineral.
 

·
Registered
Joined
·
18,929 Posts
Crasher can you post the link where you said this for future reference, I thought I saved the link but I can't find it?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #12 ·
thanks for the replies guys. I am still very stuck what or where to take it.. TBH at the moment I am leaning towards it being written off... :(

this is the fault sheet Handwriting Font Paper Paper product Writing


this is the fault happening...

as you can see.. all is good then when the car tries to go into 3rd the error comes up.. if I continue to speed up in goes up to 4th (but no higher) and as I slow down it skips 3rd back into 2nd but does not return to 1st.. just 2nd or 4th..
 

Attachments

·
Registered
Joined
·
1 Posts
Last week my golf went in for a service and I got the cambelt and water pump done. Yesterday I pulled off my drive and it seemed to "slip" a gear.. the emissions control lamp came on (yellow engine) and where the display shows the gear its in It showed a flashing spanner.
The car drives but won't go into any gears other than 2[SUP]nd[/SUP] and 4[SUP]th[/SUP] once the spanner has appeared
When the car is turned off and back on the emissions light is still on, but the gears problem seems to re-set. It then happens again when the car gets enough speed to attempt to change from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP]… again it jumps to 4[SUP]th[/SUP] and then not allowing you into any other gears..

I took it back to the VW garage that did the work last week and they tested the faults etc.
The fault found says:
005946 - Position sensor 1 for gear selector
P173A - 000 - Implausible Signal - Intermittent - MIL ON
Freeze Frame:
Fault Status: 10100000
Fault Priority: 0
Fault Frequency:9
Reset counter: 40
Mileage 24344 K
Time Indication: 0
Date 2001.14.16
Time: 15:15:21

The garage suggests it needs a new Mechatronic about £1600 Fitted
Also suggest that the Clutch and dual mass are done at the same time (because of the high mileage) at a further £1400
Total £3000… probably as much as the car is worth.

Any advice? And other options you can suggest I pursue? I spent £570 on the car last week and a further £3000 on a car with 150000 miles seems foolish.

I have a 2016 Tiguan ( 47500 miles ) - it's ying in a VW garage for over 2 weeks - can't get the replacement mechatronic unit - wish i'd seen this site before i purchased!!!!!
 
1 - 14 of 14 Posts
Top