Revs dropping in third gear

EOB

Member
Joined
Oct 18, 2020
Messages
51
Location
Malta
To understand the entire situation.

I found a lot battery acid on the battery tray.... but everything was still fine.... I still have my doubts.... Battery acid leak is not a good sign... but mechanic checked amps and it was still fine. He said test it out before we change battery.

Then the next day my start and stop started screwing around and that yellow Glow Plug/engine management light started flashing. I turned the car off and on and it disappeared. Did not go in limp mode.

Now I noticed in third gear at approx 50-60km per hour, when I accelerate suddenly.. the car power starts lagging and revs drop, for a fraction of a second at around 3k rpm. Its like it hesitates... then it continues to accelerate normally with good power.

Clutch is fine... no problems. Lots of power. Gear indicator on screen does not disappear, it labels the gear correctly. They say sign of a bad clutch is when gear indicator disappears.

Do I need a new battery? Or something else?
 
Last edited:

Crasher

Administrator
Staff member
Joined
Apr 22, 2006
Messages
30,176
Location
Nottingham, England
You need a code read before anything else. You will find the reason for the battery leaking is the battery monitoring unit which is part of the earth cable has failed, this confuses the digitally controlled via LIN BUS alternator which freaks out and sends 17+ volts to the battery which upsets it somewhat... AGM batteries don't take abuse very well. This is yet another nightmare inflicted upon us by the stupid stop/system.
 

Crasher

Administrator
Staff member
Joined
Apr 22, 2006
Messages
30,176
Location
Nottingham, England
It can be, we needed one for a Caddy in September, probaly the same part number as for yours, it arrived just before Christmas... but is easy to fit.
 

EOB

Member
Joined
Oct 18, 2020
Messages
51
Location
Malta
I turned off traction control and it was fine, even in sport mode.

I did not know traction control was so sensitive. As well I think inflation tires to proper levels made a difference in its sensitivity
 

EOB

Member
Joined
Oct 18, 2020
Messages
51
Location
Malta
I have no idea. Took it to car electrician to check.

What do recommend? Please, I am new to this stuff.
 

Crasher

Administrator
Staff member
Joined
Apr 22, 2006
Messages
30,176
Location
Nottingham, England
You need a VAG specialist who uses a system called VCDS but also has the (more expensive to use) dealer system ODIS to back it up if needed.
 

Crasher

Administrator
Staff member
Joined
Apr 22, 2006
Messages
30,176
Location
Nottingham, England
In modern cars, well maintained cars have very reliable mechanics but electrics are as vulnerable as they ever have been, more so as they have so much influence… it is ONE of the reasons I look at EV protagonists with dismay when they predict a more reliable future, they simply are clueless but have huge influence.
 

EOB

Member
Joined
Oct 18, 2020
Messages
51
Location
Malta
Ok, I will check this out. Its just strange with esc off its fine, and sports mode less evident.

In normal mode is when it happens.

I just changed air filter and changed oil as usual. Its strange
 

EOB

Member
Joined
Oct 18, 2020
Messages
51
Location
Malta
Here you go, it says "clutch temperature to high". This immediately after revs go up and down in third or fourth gear.
 

Attachments

  • Screenshot_20220117-054918_Gallery.jpg
    Screenshot_20220117-054918_Gallery.jpg
    557.7 KB · Views: 1

Crasher

Administrator
Staff member
Joined
Apr 22, 2006
Messages
30,176
Location
Nottingham, England
So it is a clutch problem, is that the first time you have seen that warning? It usually indicates that the clutch pack is worn out on the 7 speed DQ200 box.
 

EOB

Member
Joined
Oct 18, 2020
Messages
51
Location
Malta
End of last week, but I thought battery was playing as came on at same time start stop error.

I have a manual gear box and this morning it flashed it appeared 4 times.

Its evident most on third and fourth.
 
Top