Touareg MY21 Discover Premium infotainment system software glitch

Dannyb28

New member
Joined
Dec 30, 2020
Messages
4
Hi all! I have just upgraded my 2018 MK3 Touareg with the standard head unit to a new black edition MY21.

I have been trying to set up car-net and SOS etc on the "Innovision Cockpit and Discover Premium Infotainment System". What a nightmare. Error after error after error! Hours of calls with the We-Connet team and troubleshooting have left it no futher forward. It tells me it's available but unable to add the code and no access. The tracking is part of this and worrying that it's not working. The VW software team keep talking about a January massive software update and also that their servers keep going down currently.

The car even slammed on the breaks with nothing infront of it at over 40mph the other day. Then a message saying "system error please turn on the ignition" the car was still running! Seems like it has massive software issues.

My old Touareg was great no issues. I have been reading the ID range and new Golf with the same discover premium have had software issues and I was wondering if anyone had had a similar experience?

Any info would be greatly appreciated.
 

Dannyb28

New member
Joined
Dec 30, 2020
Messages
4
You are doing a job I would turn away, FAR too much stress.
It is stressing me out a little lol. I work in IT and IoT so I get the technical side. I'm trying to hope that the new software update that's promised will fix it.... But who knows. I've always had VW's and a move from Golfs to last Touareg was great. Loved it and thought I would be over the moon with this one but 9 days in... Stress is building as you say.
 

dj_ek

Member
Joined
Apr 7, 2020
Messages
71
Location
Honiton
Sounds like a reason to threaten to reject the car if it doesn’t get sorted by your dealer to me - if it bothers you.
 

Dannyb28

New member
Joined
Dec 30, 2020
Messages
4
Yeah I'm seriously considering it. But doubt I would get another one as it was a factory build.
 
Top